Citrix: Split DNS funktioniert nicht (gelöst)

Das Problem:

Bei einigen Clients, die sich über unseren Netscaler (Citrix Access Gateway) verbinden, funktioniert offensichtlich das Split-DNS nicht.
Deshalb können Verbindungen zu Mail- und Fileserver nicht hergestellt werden.
Es waren nicht alleClients betroffen.

Erster Workaround:
Um schnelle Abhilfe zu schaffen, habe ich die hosts Datei auf den Clients testhalber gepflegt. Jetzt konnten die Kollegen wieder arbeiten.

Lösung des Problems:

Ursache des Problems war der Telekom Speedport Router (Speedport W723V).
Dieser Router hat eine Firmware, die alle DNS Abfragen – egal wie der Client sie absetzt – über IPV6 ins Internet zu den Telekom DNS Servern schickt.
Also landen auch alle Anfragen vom Split-DNS im Internet.
Gelöst haben wir das so, dass wir auf allen betroffenen Clients das Protokoll IPv6 abgeschaltet haben.

ACHTUNG:
Abschalten des Protokolls auf dem Speedport bringt nichts, da man die DNS Funktion über IPv6 nicht abschalten kann – egal, was man auf der Konfigurationsseite einstellt.

 

Print Friendly, PDF & Email

Last updated by at .

Das könnte dich auch interessieren …

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.

*

Diese Website verwendet Akismet, um Spam zu reduzieren. Erfahre mehr darüber, wie deine Kommentardaten verarbeitet werden.

Dürfen wir Ihre Nutzung unserer Website zur Verbesserung unseres Angebots und Erfassung Ihrer Interessen auswerten? Dafür setzen wir Google Analytics ein. Weitere Informationen finden Sie im Impressum. Ihre Einwilligung ist freiwillig. Sie können diese jederzeit für die Zukunft widerrufen. Hier klicken um dich auszutragen.