Schlagwort-Archive: Citrix

Citrix

Fehler: 1012: Das Netscaler Gateway Plug-In konnte nicht gestartet werden

Das Problem:
Nach der Anmeldung am Citrix Netscaler wird der Tunnel nicht aufgebaut und die weiteren Webseiten (XenApp) werden nicht angezeigt.

Im Netscaler Gateway Plug-in erhält man folgenden Fehler:
Fehler: 1012–Das Netscaler Gateway Plug-In konnte nicht gestartet werden.
image

Lösung:
Das Plugin ist defekt oder hat eine Einstellung verloren. Einfach die Software Reparieren oder eine Neuinstallation durchführen.
Systemsteuerung –> Programme und Funktionen
Dort dann das “Netscaler Gateway Plug-in” suchen und netweder reparieren oder deinstallieren, um es später neu zu installieren.

Netscaler with Unified Gateway: Webmail im Vollbild

Das Problem ist schnell erklärt:

Wenn man sich am Netscaler with Unified Gateway am Webmail anmeldet, hat man erst einmal einen Balken links (1) und oben (2) am Bildrand:

Standardansicht
Standardansicht

Dadurch hat man je nach Endgerät und Auflöung zu wenig Platz, um sinnvoll mit den Mails zu arbeiten.

Die Lösung besteht darin, sich in den persönlichen Websites einen Link zum Mailserver zu hinterlegen.
Persönliche Websites  Link
Also klickt man im Bereich „Persönliche Websites“ auf „Hinzufügen“ und trägt den Link zum Webserver ein (ggfs. bei der IT nachfragen).

Link Eigenschaften

Danach erhält man einen zusätzlichen Button, der als Beschriftung den vergebenen Namen (in diesem Fall OWA) hat.
Klickt man jetzt auf den Button, statt in der linken Leiste „E-Mail“ zu verwenden, öffnet sich ein neuer Browsertab mit der Webmail-Oberfläche.
Webmeil fullscreen

 

 

Ubuntu: Citrix ICAClient / Receiver Installation 64bit

Ich musste einen Lubuntu-Client mit einer Presentation Server Farm auf 4.5 ‚verheiraten‘.

Damit ich nicht permanent mit ’sudo‘ hantieren will, mache ich mich mal zum su:

sudo su –

Jetzt die eigentlichen Schritte:

1. Die i386-Umgebung aktivieren, da es einige Abhängigkeiten gibt, die ansonsten nicht bedient werden können:

sudo dpkg –add-architecture i386
sudo apt-get update

2. Jetzt muss man das passende Paket HIER herunterladen. Bitte beachten, dass wir die Endung .deb für 64-bit benötigen. Ggfs. das USB Paket noch laden (ich habe es jetzt nicht benötigt).
Da ich es hier mit Presentation Server 4.5 zu tun hatte, habe ich das Paket 12.1.0 gewählt, da in dieser Umgebung kein Citrix Receiver mit

3. Jetzt die Voraussetzungen schaffen:
apt-get install libmotif4:i386 nspluginwrapper lib32z1 libc6-i386 libxp6:i386 libxpm4:i386 libasound2:i386

4. Nun erzeugt man im Download-Ordner einen neuen Ordner ‚ica_temp‘:
mkdir ica_temp

5. … und packt das Installationspaket aus:
dpkg-deb -x icaclient_12.1.0_amd64.deb ica_temp
dpkg-deb –control icaclient_12.1.0_amd64.deb ica_temp/DEBIAN

6. Die Datei ‚control‘ unter DEBIAN anpassen:
vi ica_temp/DEBIAN/control

dort muss die Zeile ‚Depends‘ durch folgende ersetzt werden:
Depends: libc6-i386 (>= 2.7-1), lib32z1, nspluginwrapper, libxp6:i386, libxpm4:i386

und anpassen der Datei ‚postinst‘ in DEBIAN:
vi ica_temp/DEBIAN/postinst

In der Zeile 2648 steht
echo $Arch|grep „i[0-9]86“ >/dev/null
das bitte ersetzen durch
echo $Arch|grep -E „i[0-9]86|x86_64“ >/dev/null

Hintergrund: Die Ausgabe des Befehls ‚uname-m‘ hat als Ergebnis x86_64. Diese Ergebnis wird durch die ursprüngliche Abfrage nicht abgefangen.

7. Wieder zusammenpacken und installieren:

dpkg -b ica_temp icaclient-modified.deb

dpkg -i icaclient-modified.deb

8. Das Verzeichnis ica_temp kann jetzt weg:
rm -r ica_temp

9. Noch ein paar Zertifikate verknüpfen, damit man nicht auf Zertifikats-Fehler stößt (Mozilla hat da mehr im Angebot als das Paket ca-certificates):
ln -s /usr/share/ca-certificates/mozilla/* /opt/Citrix/ICAClient/keystore/cacerts/
c_rehash /opt/Citrix/ICAClient/keystore/cacerts/

Hoffe es hilft!

 

Citrix Receiver Fehlernummer 2320 Citrix Online Plug-in-Konfigurationsmanager

Problem:

Wenn ein Client versucht eine Anwendung über das Citrix Online Plugin Full zu öffnen, erscheint folgende Fehlermeldung (Fehlernummer 2320):

Fehlernummer 2320 Citrix Online Plug-in-Konfigurationsmanager: Kein Wert konnte für (AllowHotkey) gefunden werden, der alle Lockdownanforderungen erfüllt. Die gültigen Lockdownanforderungen können u.U. Konflikte verursachen.

Lösung:

Es muss ein Registry Key geändert werden:
Unter
HKEY_LOCAL_MACHINE\Software\Citrix\ICA Client\Engine\Lockdown Profiles\All Regions
Enablelockdown von 1 zu 0 ändern.

Danach einmal die Anwendungsaktualisierung durchführen und es sollte gehen.

Lösung 2:

Ein anderer Tip, den ich gefunden habe:

  • 32-Bit System: HKEY_LOCAL_MACHINE\SOFTWARE\Citrix\ICA Client\Engine\Lockdown Profiles\All Regions\Lockdown\Virtual Channels\Control
  • 64-Bit System: HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Citrix\ICA Client\Engine\Lockdown Profiles\All Regions\Lockdown\Virtual Channels\Control

dort dann den Eintrag „ClientHostedApps“ suchen und löschen, falls der Eintrag vorhanden ist. Bei mir war der Eintrag allerdings nicht da.

Lösung 3:

CTX137494 – Receiver Clean-Up Utility

Deinstallieren des vorhandenen Clients mit dem Citrix Utility und danach eine saubere Neuinstallation. Häufig wird der Fehler nämlich durch eine fehlerhafte Installation hervorgerufen. Gelegentlich kann auch ein direktes Update von früheren Versionen dazu führen, dass es in der Registry falsche Einträge gibt.

Netscaler: 3006: Das Plug-in konnte nicht gestartet werden. [gelöst]

Problem:

Bei Verwendung des Citrix Netscalers (Access Gateway) erscheint bei der „Prüfung der Systemkonfiguration auf dem Gerät“ folgende Meldung:

3006: Das Plug-in konnte nicht gestartet werden. Wenden Sie sich an Ihren Helpdesk oder Systemadministrator.

Lösung:

Für die entsprechende Einwahlseite muss der Kompatibilitätsmodus aktiviert werden.

Also unter Windows7 zunächst ein Aero-Design auswählen, da ansonsten im IE die entsprechende Menüleise nicht angezeigt wird.
Danach Rechtsklick in die obere InternetExplorer Leiste und die Menüleiste einschalten.

Dort dann die Einstellungen zur Kompatibilitätsansicht auswählen und die VPN URL wie oben gezeigt hinzufügen.